Speedy Attack Targets Web Servers with Outdated Linux Kernels

Web servers running a long-outdated version of the Linux kernel were attacked with dramatic speed over two days last week, Cisco Systems said on Thursday.

Web servers running a long-outdated version of the Linux kernel were attacked with dramatic speed over two days last week, Cisco Systems said on Thursday.

All the affected servers were running the 2.6 version, first released in December 2003, of the Linux kernel, which is the core of the operating system. Most were running a 2.6 Linux kernel version released in 2007 or earlier, wrote Martin Lee, technical lead of Threat Intelligence for Cisco.

"Systems that are unmaintained or unsupported are no longer patched with security updates," Lee wrote. "When attackers discover a vulnerability in the system, they can exploit it at their whim without fear of it being remedied."

After the Web server has been compromised, the attackers slip in a line of JavaScript to other JavaScript files within the website. That code bounces the website's visitors to a second compromised host, which runs another JavaScript file.

"The two-stage process allows attackers to serve up a variety of malicious content to the visitor," Lee wrote.

The visitor is then served pay-per-view fraud pages, which load up advertisements. Other clues indicate some visitors may be served malicious software, he wrote.

One in 15 of Cisco's clients using its Cloud Web Security product had one of their users attempt to request one of the malicious URLs, Lee wrote. The company saw 400 distinct hosts, with a high number in the U.S. and Germany, affected on March 17 and 18, showing "the spread of this attack has been dramatic," he wrote.

About 2,700 URLs have been affected. Because the attack centers on compromising legitimate websites, "security awareness campaigns that train users to be wary of unknown websites may not be effective against trusted websites that become compromised to serve malware," Lee wrote.

The campaign highlights the need for system administrators to continually update their systems.

"Large numbers of vulnerable unpatched systems on the Internet are tempting targets for attackers," Lee wrote. "Such systems can be used as disposable one-shot platforms for launching attacks."

Send news tips and comments to jeremy_kirk@idg.com. Follow me on Twitter: @jeremy_kirk

Join the discussion
Be the first to comment on this article. Our Commenting Policies