
<!DOCTYPE html>
<!--[if lt IE 7]>  <html lang="en" class="lt-ie9 lt-ie8 lt-ie7" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 7]> <html lang="en" class="lt-ie10 lt-ie9 lt-ie8" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 8]> <html lang="en" class="lt-ie10 lt-ie9" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 9]> <html lang="en" class="lt-ie10" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <!--<![endif]-->
<head>
<!-- ad-related js -->
<script src="/www/js/jquery/jquery-1.10.2.min.js"></script>
<script src="/www/js/init_device.js"></script>
<script type="text/javascript" src="/www/js/jquery/jquery_cookie.js"></script>
<script type="text/javascript" src="/www/js/ads/gpt_includes.js?v=20180405115135"></script>
<script type="text/javascript">if(adLayer==null||adLayer=='undefined'){var adLayer=[];}adLayer["itemType"]="article";</script>
<script type="text/javascript">try{IDG.GPT.unitName="/8456/IDG.US_E_CIO.com";}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.unitName=IDG.GPT.unitName+"/"+"software_section";}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}var global_ShowSuper=true;var global_ShowHero=false;var url=window.location.href;if(url.indexOf("?")>1){url=url.split('?')[0];}try{IDG.GPT.addTarget("URL",encodeURIComponent(url));}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("zone",'article/customer-relationship-management');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("channel",'software');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("articleId",'3267576');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("type",'opinion');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("typeId",'5');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("templateType",'article-default');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("categoryIds",[3732,3029]);}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("categorySlugs",['customer-relationship-management','software']);}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{if(null!=IDG.GPT.getQsVal("env")){IDG.GPT.addTarget("env",IDG.GPT.getQsVal("env").replace(/\W/g,""));}}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("author",'David Taber');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("page_type",'');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("insiderContent",'false');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}</script>
<script type="text/javascript"></script>
<script src="/www.idge/js/thm_pre.js?v=20180405115135"></script>
<script type="text/javascript">(function(){try{var proximic_data={"data":["300003","121100","112200","112202","112204","112219","240000","240002","240003","240004","240001","240005","240006","240007","240008","240009","240011","240012","240013","240014","240017","240015","240016","e2co9k","r03wnl","folvaf","ycjxce","0nr7l6","pytywb","bkwp85","yn3dkv","9mtm4u","agt9m3","qh9ovz","rivjct","skl8g2","ablabm"]};IDG.GPT.addTarget("proximic",proximic_data.data);}catch(e){console.log("Error: "+e);}})();</script>
<script>var isMobile=(typeof IDG.DEVICE!=='undefined')?IDG.DEVICE.isMobile():false;try{IDG.GPT.addBiddingParams("yieldbotPsn",(isMobile?"dda9":"c1ed"));IDG.GPT.addBiddingParams("appnexusPlacementId",(isMobile?"6451281":"6352906"));IDG.GPT.addBiddingParams("TriLiftPrefix","cio_ros_");}catch(e){console.log("Error in adding bidding params: "+e);}</script>
<script src="/www/js/ads/narf_prebid.js?v=20180405115135"></script>
<script type="text/javascript" src="/www/js/ads/gpt_starter.js?1234"></script>
<script type="text/javascript" src="/www/js/ads/gpt_launcher.js"></script>
<!-- metas -->
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"/>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
<title>Building a customer community: 13 critical questions to get started | CIO</title>
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="canonical" href="https://www.cio.com/article/3267576/customer-relationship-management/building-a-customer-community-13-critical-questions-to-get-started.html"/>
<meta itemprop="url" content="https://www.cio.com/article/3267576/customer-relationship-management/building-a-customer-community-13-critical-questions-to-get-started.html"/>
<meta name="description" content="Salesforce, WordPress, Simplemachines, BB engines…they all have demos for community-building tools that will daze and amaze. But which one’s for you? Don’t go shopping until you’ve answered these questions."/>
<meta name="news_keywords" content="customer portal,customer community"/>
<meta name="DC.date.issued" content="2018-04-09T02:56-05:00"/>
<meta name="date" content="2018-04-09"/>
<link rel="amphtml" href="https://www.cio.com/article/3267576/customer-relationship-management/building-a-customer-community-13-critical-questions-to-get-started.amp.html"/>
<meta property="og:title" content="Building a customer community: 13 critical questions to get started">
<meta property="og:description" content="Salesforce, WordPress, Simplemachines, BB engines…they all have demos for community-building tools that will daze and amaze. But which one’s for you? Don’t go shopping until you’ve answered these questions.">
<meta property="og:image" content="https://images.idgesg.net/images/article/2018/01/group-of-people-applauding_agreement_community-100746938-large.3x2.jpg"/>
<meta property="og:image:width" content="700"/>
<meta property="og:image:height" content="467"/>
<meta itemprop="image" content="https://images.idgesg.net/images/article/2018/01/group-of-people-applauding_agreement_community-100746938-large.3x2.jpg">
<meta itemprop="thumbnailURl" content="https://images.idgesg.net/images/article/2018/01/group-of-people-applauding_agreement_community-100746938-large.3x2.jpg"/>
<link rel="image_src" href="https://images.idgesg.net/images/article/2018/01/group-of-people-applauding_agreement_community-100746938-large.3x2.jpg"/>
<meta name="twitter:image" content="https://images.idgesg.net/images/article/2018/01/group-of-people-applauding_agreement_community-100746938-large.3x2.jpg"/>
<meta property="og:type" content="article"/>
<meta name="author" content="David Taber">
<meta property="og:site_name" content="CIO"/>
<meta property="fb:app_id" content="129182073794488"/>
<meta property="og:url" content="https://www.cio.com/article/3267576/customer-relationship-management/building-a-customer-community-13-critical-questions-to-get-started.html">
<!-- Use Twitter Summary Card with Large Image for articles and videos -->
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@CIOonline">
<meta name="twitter:description" content="Salesforce, WordPress, Simplemachines, BB engines…they all have demos for community-building tools that will daze and amaze. But which one’s for you? Don’t go shopping until you’ve answered these questions.">
<meta name="rating" content="General">
<meta name="robots" content="NOODP,NOYDIR"/>
<meta name="google-site-verification" content="kgXSqlEuYT_m_uwWCByBpKmiaVLisiAi9bPjzyelGTw"/>
<meta name="msvalidate.01" content="B6D65511A0CC5522E695818081C251B8"/>
<!-- Sailthru -->
<meta name="sailthru.tags" content="customer-relationship-management,software,david-taber,opinion,medium"/>
<meta name="sailthru.image.thumb" content="https://images.idgesg.net/images/article/2018/01/group-of-people-applauding_agreement_community-100746938-small.jpg"/>
<meta name="sailthru.image.full" content="https://images.idgesg.net/images/article/2018/01/group-of-people-applauding_agreement_community-100746938-large.3x2.jpg"/>
<meta name="sailthru.title" content="Building a customer community: 13 critical questions to get started"/>
<meta name="sailthru.description" content="Salesforce, WordPress, Simplemachines, BB engines…they all have demos for community-building tools that will daze and amaze. But which one’s for you? Don’t go shopping until you’ve answered these questions."/>
<meta name="displaytype" content="article"/>
<meta name="source" content="cio"/>
<meta name="category" content="crm,software"/>
<meta name="storytype" content="opinion"/>
<!-- pagination -->
<link id="mobile-size" rel="stylesheet" href="/www.idge/css/inline-header-mobile.css?v=20180405115135"/>
<script>if(window.matchMedia("(min-width: 768px)").matches){document.getElementById('mobile-size').insertAdjacentHTML('afterend','<link id="desktop-size" rel="stylesheet" href="/www.idge/css/inline-header.css?v=20180405115135" />');}</script>
<link rel="stylesheet" href="/www.idge.cio/css/inline-header.css?v=20180405115135"/>
<!-- css -->
<link rel="stylesheet" href="/www.idge/css/normalize.css"/>
<link rel="stylesheet" href="/www.idge/css/prettify.css"/>
<link rel="stylesheet" href="/www.idge.ans/js/select2-3.5.0/select2.css"/>
<link rel="stylesheet" href="/www/css/article.css?v=20180405115135"/>
<link rel="stylesheet" href="/www.idge/css/insider-promo-styles.css?v=20180405115135"/>
<link rel="stylesheet" href="/www.idge/css/print.css" media="print"/>
<link rel="stylesheet" href="/www.idge.cio/css/article.css?v=20180405115135"/>
<link rel="stylesheet" href="/www.idge/css/webfonts/ss-social.css"/>
<link rel="stylesheet" href="/www.idge/css/webfonts/ss-standard.css"/>
<!--[if lte IE 8]>  
		<link href="/www.idge/css/webfonts/ss-ie8.css" rel="stylesheet" />
	<![endif]-->
<script type="text/javascript" src="//fonts.staticworld.net/sqc0dqh.js"></script>
<script type="text/javascript">try{Typekit.load();}catch(e){}</script>
<!--  fav and touch icons -->
<link rel="shortcut icon" type="image/x-icon" href="https://idge.staticworld.net/cio/favicon.ico"/>
<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://idge.staticworld.net/cio/CIO_logo_144x144.png"/>
<link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://idge.staticworld.net/cio/CIO_logo_114x114.png"/>
<link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://idge.staticworld.net/cio/CIO_logo_72x72.png"/>
<link rel="apple-touch-icon-precomposed" sizes="57x57" href="https://idge.staticworld.net/cio/CIO_logo_57x57.png"/>
<link rel="apple-touch-icon" href="https://idge.staticworld.net/cio/CIO_logo_300x300.png"/>
<!-- LiveRamp Sources -->
<script type="text/javascript" src="//storage.googleapis.com/cdn.pippio.com/sdk/pippio.min.js" async></script>
<script src="/www/js/utils/liveRamp.js"></script>
<!-- End of LiveRamp -->
<script src="/www.idge.ans/js/select2-3.5.0/select2.js"></script>
<script>$(document).ready(function(){$("select#country").select2({placeholder:"country",minimumResultsForSearch:Infinity,allowClear:true});$("#jobPosition").select2({placeholder:"position",minimumResultsForSearch:Infinity,allowClear:true});$("#jobFunction").select2({placeholder:"function",minimumResultsForSearch:Infinity,allowClear:true});$("#companySize").select2({placeholder:"company size",minimumResultsForSearch:Infinity,allowClear:true});$("#industry").select2({placeholder:"industry",minimumResultsForSearch:Infinity,allowClear:true});});</script>
<script>var brandCode="cio";var brandName="CIO";var regDebugLog=false;var regApiUrl="https://regdev.idge.int/api/";var tokenPrefix='www';var tokenSuffix='.com/insider/token?';var brandDomain=".cio.com";var insiderContentType="article";var notEmptyArticle=false;var notEmptyMediaResource=false;var isInsiderPremium=false;var isResourceInsiderPremium=false;regApiUrl="https://reg.idgenterprise.com/api/";regDebugLog=false;tokenPrefix="http://www";tokenSuffix="/insider/token";notEmptyArticle=true;</script>
<script src="/www/js/utils/alc_hashes.js"></script>
<script src="/www/js/insider/insider_reg_api.js?v=20180405115135"></script>
<script src="/www/js/insider/jquery.maskedinput-1.4.min.js"></script>
<script>$(document).ready(function(){if(typeof(IDG.insiderReg.readCookie('nsdr'))!=='undefined'){$('#welcome-message').show();IDG.insiderReg.personalize();}else{$('.signin-register').show();}});</script>
<!-- Begin Eloqua Tracking -->
<script type="text/javascript" src="/www/js/analytics/eloqua/elqCfg.js"></script>
<script type="text/javascript" src="/www/js/analytics/eloqua/elqImg.js"></script>
<script type="text/javascript" src="/www/js/analytics/eloqua/elqFCS.js"></script>
<script type="text/javascript" src="/www/js/analytics/eloqua/elqScr.js"></script>
<script type="text/javascript" src="/www/js/analytics/eloqua/elqIDG.js"></script>
<script type="text/javascript">IDG=window.IDG||{};IDG.PageInfo=IDG.PageInfo||{};IDG.PageInfo=function(){return{eloqua_type:"article",eloqua_topic:"applications"};}();var elqCustomerGUID="";if(this.GetElqCustomerGUID&&typeof GetElqCustomerGUID==="function"){elqCustomerGUID=GetElqCustomerGUID();}IDG.Eloqua.invoke_flash();</script>
<!-- End Eloqua Tracking -->
<script type="text/javascript">var g_arrModules=new Array();</script>
<script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
<script src="/www/js/ads/ads.js"></script>
<script>var insiderSignedIn=document.cookie.indexOf("nsdr")>-1;var dlJobFunction='';var dlJobPosition='';var dlIndustry='';if(insiderSignedIn){var insiderToken=IDG.insiderReg.readCookie("nsdr");var tokens=IDG.insiderReg.readCookieProperty(insiderToken);if(!(tokens['jobPosition']===undefined)){dlJobPosition=tokens['jobPosition'];}if(!(tokens['jobFunction']===undefined)){dlJobFunction=tokens['jobFunction'];}if(!(tokens['industry']===undefined)){dlIndustry=tokens['industry'];}}insiderSignedIn=insiderSignedIn.toString();var sincePublished='0 days';sincePublished=sincePublished.split(" ")[0];dataLayer=[{'articleId':'3267576','articleDisplayId':'1','articleTitle':'Building a customer community: 13 critical questions to get started','articleType':'Opinion','audience':'enterprise','author':'David Taber','blogName':'','brandpost':'false','categoryIdList':'3732,3029','categoryIdPrimary':'3732','contentStrategy':'','contentType':'opinion','datePublished':'2018-04-09','dateUpdated':'','daysSincePublished':sincePublished,'daysSinceUpdated':'','displayType':'article','environment':'production','ga_enabled':'true','gaTrackingId':'UA-300704-2','geolocEnabled':'true','industry':dlIndustry,'insiderSignedIn':insiderSignedIn,'isBlog':'false','isInsiderContent':'false','isICN':'false','jobFunction':dlJobFunction,'jobPosition':dlJobPosition,'pageNumber':'1','platform':'Web','primaryCategory':'crm','primaryCategoryList':'crm,software','property':'cio','propertyCountry':'US','purchaseIntent':'awareness','sailthruCustomerId':'55c534f17a14fd32650150a5b301b6fc','skimlinksId':'111346X1569474','source':'cio','sponsorName':'','tags':'','videoAutoplay':'false','articleHasVideo':'false'}];</script>
<script type="text/javascript">var _sf_async_config={};_sf_async_config.uid=29363;_sf_async_config.path="/article/3267576/customer-relationship-management/building-a-customer-community-13-critical-questions-to-get-started.html";_sf_async_config.title="Building a customer community: 13 critical questions to get started | CIO";_sf_async_config.domain="cio.com";if(window.location.href.indexOf("video")&&true){_sf_async_config.playerdomain=_sf_async_config.domain.replace("www.","");}_sf_async_config.useCanonical=true;_sf_async_config.sections="customer-relationship-management";_sf_async_config.authors="David Taber";</script>
<!-- Page hiding snippet (recommended)  -->
<style>.async-hide { opacity: 0 !important} </style>
<script>(function(a,s,y,n,c,h,i,d,e){s.className+=' '+y;h.start=1*new Date;h.end=i=function(){s.className=s.className.replace(RegExp(' ?'+y),'')};(a[n]=a[n]||[]).hide=h;setTimeout(function(){i();h.end=null},c);h.timeout=c;})(window,document.documentElement,'async-hide','dataLayer',4000,{'GTM-WSG46DM':true});</script>
<!-- Modified Analytics tracking code with Optimize plugin -->
<script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');ga('create','UA-300704-2','auto');ga('require','GTM-WSG46DM');</script>
<script>var dataLayer=window.dataLayer=window.dataLayer||[];var adBlockStatus='false';function AdBlockEnabled(){var ad=document.createElement('ins');ad.className='AdSense';ad.style.display='block';ad.style.position='absolute';ad.style.top='-1px';ad.style.height='1px';if(document.body!=null){document.body.appendChild(ad);var isAdBlockEnabled=!ad.clientHeight;document.body.removeChild(ad);}return isAdBlockEnabled;}if(AdBlockEnabled()!=undefined){adBlockStatus=AdBlockEnabled().toString();}if(document.body==null){if(window.canRunAds===undefined){adBlockStatus='true';}else{adBlockStatus='false';}}dataLayer.push({'adBlockStatus':adBlockStatus});</script>
<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?GTM-NCMJGX" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-NCMJGX');</script>
<!-- End Google Tag Manager -->
<script>function bindPerformanceMarks(){googletag.pubads().addEventListener('slotRenderEnded',function(event){var slotId=event.slot.getSlotElementId();if(slotId=='gpt-overlay'&&!event.isEmpty){performance.mark("mark_welcome_render_begin");}});googletag.pubads().addEventListener('slotOnload',function(event){var slotId=event.slot.getSlotElementId();if(slotId=='gpt-overlay'){performance.mark("mark_welcome_render_end");}});googletag.pubads().addEventListener('impressionViewable',function(event){var slotId=event.slot.getSlotElementId();if(slotId=='gpt-overlay'){performance.mark("mark_welcome_impression_viewable");w=performance.getEntriesByType("mark").filter(function(mrk){return mrk.name.indexOf("mark_welcome")>-1;});gtmEvent={'event':'gatherWelcomeAdMarks'};for(var j=0;j<w.length;j++){console.log("+++Mark only entry["+j+"]: name = "+w[j].name+"; startTime = "+w[j].startTime);gtmEvent[w[j].name]=w[j].startTime;}var dataLayer=window.dataLayer=window.dataLayer||[];dataLayer.push(gtmEvent);}});}try{IDG.GPT.googleCommandPush(bindPerformanceMarks);}catch(e){console.log('error binding performance marks: '+e);}</script>
<script src="https://www.google.com/recaptcha/api.js" async defer></script>
</head>
<body id="article3267576" class="article cio">
<!-- Begin welcome ad overlay - gpt-overlay position  -->
<div id="superadunit" class="hidden">
<div class="ad">
<div class="ad-header">
<div class="brand-logo"></div>
<a href="javascript:unhide('superadunit');" id="superstitial-text">Close Ad</a>
</div>
<div id="gpt-overlay" class=" ad-container">
<script type="text/javascript">IDG.GPT.addDisplayedAd("gpt-overlay","true");IDG.GPT.displayGoogleTagSlot('gpt-overlay');</script>
</div>
</div>
</div>
<!--  End welcome ad overlay - gpt-overlay position -->
<!-- BEGIN PAGE HEADER -->
<header id="banner">
<script>if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('.main-header').insertBefore($('#banner .ad'));}</script>
<div class="topics-wrap">
<section class="topics">
<nav id="scrollable">
<!-- blx4 #877 blox4.raw_link_list  -->
<ul>
<li class="header">Quick Links<span class="colon">:</span></li>
<li><a href="/article/3250845/digital-transformation/state-of-the-cio-2018-it-business-alignment-finally-gets-real.html">State of the CIO 2018</a></li>
<li><a href="/tag/cio-digital-magazine/">Digital Magazine</a></li>
<li><a href="/video/series/8534/cio-leadership-live">CIO Leadership Live</a></li>
<li><a href="http://www.cio100.com" target="_blank" rel="nofollow">CIO100 Awards</a></li>
<li><a href="/newsletters/signup.html">Newsletters</a></li>
<li><a href="/video/">Video</a></li>
<li><a href="/resources/">Resources/White Papers</a></li>
<li><a href="/jobs">Job Search</a></li>
</ul>
</nav>
<div class="fading-gradient"></div>
<nav class="tools">
<ul class="user">
<li class="search-icon"><a href="#search" id="search-btn"><i class="ss-icon">Search</i></a></li>
</ul>
<ul class="social">
<li><a href="https://twitter.com/CIOonline" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Twitter')"><i class="ss-icon ss-social-circle ss-twitter"></i></a></li>
<li><a href="https://www.linkedin.com/company/cio-online" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('LinkedIn')"><i class="ss-icon ss-social-circle brand ss-linkedin"></i></a></li>
<li><a href="https://www.facebook.com/CIOfacebook" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Facebook')"><i class="ss-icon ss-social-circle brand ss-facebook"></i></a></li>
<li><a href="https://plus.google.com/+CIOOnline" itemprop="sameAs" rel="publisher" target="_blank" onclick="brandFollowTrack('Google+')"><i class="ss-icon ss-social-circle brand ss-googleplus"></i></a></li>
<li><a href="https://www.youtube.com/user/CIOtv" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('YouTube')"><i class="ss-icon ss-social-circle brand ss-youtube"></i></a></li>
<li><a href="/index.rss" target="_blank"><i class="ss-icon ss-social-circle ss-rss"></i></a></li>
<li class="more-social"><i class="ss-icon ss-ellipsis"></i></li>
</ul>
</nav>
</section>
</div>
<div id="sticky-anchor"></div>
<section id="sticky-head" class="main">
<div class="wrapper">
<div class="masthead">
<button><i class="ss-icon ss-rows"></i></button>
<a href="/"><span class="ir logo">cio</span></a>
<!--
	            	<img class="print-only" src="/www.idge.cio/images/cio-logo-print.png">
	            	-->
<img class="print-only" src="//idge.staticworld.net/cio/cio-logo-print.png">
</div>
<div id="reading-tools-wrapper">
<nav class="tools">
<ul class="user">
</ul>
</nav>
</div>
<div class="insider-signin">
<span class="signin-register">
<a href="/learn-about-insider/"><span class="insider"></span></a> <a href="javascript://" onclick="IDG.insiderReg.registerLinkEvent('insider-reg-signin')" class="js-open-modal signin" data-modal-id="insider-popup">Sign In</a> <span class="divider">|</span> <a href="javascript://" onclick="IDG.insiderReg.registerLinkEvent('insider-reg-form-short')" class="js-open-modal register" data-modal-id="insider-popup">Register</a>
</span>
<div id="welcome-message" class="insider-list">
<div id="insider-selector">
<div id="insider-welcome" class="label"></div>
<div class="stories">
<div class="personalization">Hi<span id="person-first-name"></span>! Here are the latest Insider stories.</div>
<ul>
<li><a href="/article/3267641/leadership-management/insurance-firm-banks-on-change-management-in-digital-overhaul.html">Insurance firm banks on change management in digital overhaul</a></li>
<li><a href="/article/2414672/careers-staffing/careers-staffing-leaving-your-job-what-you-can-and-can-t-take-with-you.html">Leaving your job: What you can and can’t take with you</a></li>
<li><a href="/article/3265731/collaboration/slack-anchors-digital-transformation-at-20th-century-fox.html">Slack anchors digital transformation at 21st Century Fox</a></li>
<li><a href="/article/3158677/careers-staffing/8-common-resume-mistakes-and-how-to-fix-them.html">8 common resume mistakes (and how to fix them)</a></li>
</ul>
<div class="sign-out-link">
<a class="more-insider" href="/insider/">More Insider</a>
<a class="sign-out" href="javascript://" onclick="IDG.insiderReg.logout()">Sign Out</a>
</div>
</div>
</div>
</div>
</div>
<script>$('.signin-register').hide();$('#welcome-message').hide();</script>
</div>
</section>
<section class="tools-expand  ">
<form class="search" id="search-form" action="/search">
<label for="search-box">Search for</label>
<input type="text" name="query" id="banner-search-term" value="" class="searchbox-input-class"/>
<input type="submit" id="banner-search-submit" value="Go"/>
<input type="hidden" name="contentType" value="article,resource"/>
<div class="search-suggest">Suggestions for you</div>
</form>
<div class="user">
<form>
<label for="login-email">Insider email</label> <input id="login-email" type="text"/>
</form>
</div>
</section>
<div id="sticky-anchor-nav"></div>
<nav id="sticky-nav" class="main">
<ul class="topnav">
<li><a href="/category/analytics/">Analytics</a>
</li>
<li><a href="/category/artificial-intelligence/">Artificial Intelligence</a>
</li>
<li><a href="/category/big-data/">Big Data</a>
</li>
<li><a href="/category/cio100/">CIO 100 Symposium and Awards</a>
</li>
<li><a href="/category/careers-staffing/">Careers</a>
</li>
<li><a href="/category/cloud-computing/">Cloud Computing</a>
</li>
<li><a href="/category/collaboration/">Collaboration</a>
</li>
<li><a href="/category/consumer-electronics/">Consumer Technology</a>
</li>
<li><a href="/category/developer/">Developers</a>
</li>
<li><a href="/category/digital-transformation/">Digital Transformation</a>
</li>
<li><a href="/category/hardware/">Hardware</a>
</li>
<li><a href="/category/healthcare/">Health Care</a>
</li>
<li><a href="/category/it-industry/">IT Industry</a>
</li>
<li><a href="/category/leadership-management/">IT Leadership</a>
</li>
<li><a href="/category/it-strategy/" class="hasChildren">IT Strategy<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/it-strategy/">All IT Strategy</a></li>
<li><a href="/category/cio-role/">CIO Role</a></li>
<li><a href="/category/cmo-role/">CMO Role</a></li>
<li><a href="/category/innovation/">Innovation</a></li>
<li><a href="/category/outsourcing/">Outsourcing</a></li>
</ul>
</li>
<li><a href="/category/infrastructure/" class="hasChildren">Infrastructure<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/infrastructure/">All Infrastructure</a></li>
<li><a href="/category/data-center/">Data Centers</a></li>
<li><a href="/category/networking/">Networking</a></li>
<li><a href="/category/infrastructure-storage/">Storage</a></li>
<li><a href="/category/virtualization/">Virtualization</a></li>
</ul>
</li>
<li><a href="/category/internet/" class="hasChildren">Internet<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/internet/">All Internet</a></li>
<li><a href="/category/marketing/">Marketing</a></li>
</ul>
</li>
<li><a href="/category/mobile/" class="hasChildren">Mobile<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/mobile/">All Mobile</a></li>
<li><a href="/category/mobile-apps/">Mobile Apps</a></li>
<li><a href="/category/smartphones/">Smartphones</a></li>
<li><a href="/category/tablets/">Tablets</a></li>
<li><a href="/category/wearable-technology/">Wearables</a></li>
</ul>
</li>
<li><a href="/category/operating-systems/" class="hasChildren">Operating Systems<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/operating-systems/">All Operating Systems</a></li>
<li><a href="/category/linux/">Linux</a></li>
<li><a href="/category/windows/">Windows</a></li>
</ul>
</li>
<li><a href="/category/security/" class="hasChildren">Security<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/security/">All Security</a></li>
<li><a href="/category/cyber-attacks-espionage/">Cybersecurity</a></li>
<li><a href="/category/disaster-recovery/">Disaster Recovery</a></li>
<li><a href="/category/malware/">Malware</a></li>
<li><a href="/category/privacy/">Privacy</a></li>
<li><a href="/category/regulation/">Regulation</a></li>
</ul>
</li>
<li><a href="/category/software/">Software</a>
</li>
<li><a href="/category/virtual-reality/">Virtual Reality and Augmented Reality</a>
</li>
</ul>
<ul class="secondary">
<li><a href="/about/contactus.html">Contact Us</a></li>
<li>
<a href="/about/subscription-services.html" class="hasChildren">
Magazine
<span class="ss-icon ss-navigatedown"></span>
</a>
<ul class="subnav">
<li><a href="/about/subscription-services.html">Subscription Services</a></li>
<li><a href="/magazine">Archive</a></li>
</ul>
</li>
<li><a href="/news/">News</a></li>
<li><a href="/opinion/">Opinion</a></li>
<li><a href="/resources/">Resources</a></li>
<li><a href="/slideshows/">Slideshows</a></li>
<li><a href="/video/">Video</a></li>
<li>
<a href="#" class="hasChildren">More <span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="http://council.cio.com/" target="_blank" rel="nofollow">CIO Executive Council</a></li>
<li><a href="http://www.ereg.me/IDGEvents" target="_blank" rel="nofollow">CIO Events</a></li>
<li><a href="/newsletters/signup.html">Newsletters</a></li>
<li><a href="/about/rss.html">RSS</a></li>
</ul>
</li>
<li><a href="/blogs/">Blogs</a></li>
</ul>
</nav>
<script>if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('div.insider-signin').prependTo('section.topics nav.tools');}</script>
<script>$(document).ready(function(){if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$("nav ul li a.hasChildren").attr("href","#").addClass('notMobile');$('nav#sticky-nav ul.secondary').addClass('topnav');}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$("nav#sticky-nav > ul").switchClass("topnav","primary");}});</script>
<script>if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('#sticky-anchor, section.main, section.topics, section.tools-expand, #sticky-anchor-nav, nav.main').insertBefore($('#banner .ad'));$(document).ready(function(){$('#banner section.tools-expand').addClass('top-margin');});}</script>
</header>
<script>$(document).ready(function(){$('body').addClass('insider-plus');var headerHeight=$('header#banner').height();$('header#banner nav#sticky-nav.main.no-stick').css("top",headerHeight);if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){var stickyHeaderHeight=$('section.topics').height()+$('#sticky-head.main').height();stickyHeaderHeight=stickyHeaderHeight-8;}var supportsOrientationChange="onorientationchange"in window,orientationEvent=supportsOrientationChange?"orientationchange":"resize";if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){window.addEventListener(orientationEvent,function(){var top=$('section#sticky-head.main').offset().top;if(top<170){top=0;}else{top=top-50;}if(window.orientation==90||window.orientation==-90){window.scrollTo(0,top);}},false);}if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)&&$thm.deviceHeight()<768){if($('html').hasClass('touch')){$('#insider-popup.modal-box .modal-body').addClass('short');}else{$('#insider-popup.modal-box .modal-body').addClass('short-desk');}}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){window.addEventListener(orientationEvent,function(){var top=$('section#sticky-head.main').offset().top;if(top<50){top=5;}else{top=top-40;}if(window.orientation==90||window.orientation==-90){window.scrollTo(0,top);}},false);}var ua=navigator.userAgent.toLowerCase();var isAndroid=ua.indexOf("android")>-1;window.addEventListener(orientationEvent,function(){if(isAndroid&&(screen.width==600||screen.width==960)){location.reload(true);}},false);if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.desktop)&&!$('html').hasClass('touch')){$("ul.social li.more-social").mouseenter(function(){$('ul.social > li').addClass('display-icon');});$("ul.social").mouseleave(function(){$('ul.social > li').removeClass('display-icon');});};if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)&&$('html').hasClass('touch')){$("ul.social li.more-social").click(function(){$('ul.social > li').toggleClass('display-icon');});};$('.searchbox-input-class').each(function(){$(this).change(function(){var qStr=$(this).val();if($(this).val().indexOf('@')!=-1){qStr=qStr.replace(/@/g,' ');$(this).val(qStr);}});});});function sticky_relocate(){var headerHeight=$('header#banner').height();var winHeight=$(window).height();if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.wide)){winHeight=winHeight-40;if(window.orientation==90||window.orientation==-90){winHeight=winHeight+50;}}else if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)&&!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.wide)){winHeight=winHeight+40;}else{winHeight=winHeight+10;}$('#banner nav#sticky-nav.main').css("height",winHeight);if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){var window_top=$(window).scrollTop();var div_top=$('#sticky-anchor').offset().top;if(window_top>div_top){$('#sticky-head').addClass('stick');$('#page-wrapper').addClass('top-pad');$('#banner .ad').addClass('top-margin');}else{$('#sticky-head').removeClass('stick');$('#page-wrapper').removeClass('top-pad');$('#banner .ad').removeClass('top-margin');}}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('section.topics').addClass('stick-topics');$('#sticky-head').addClass('stick-head');$('#page-wrapper').addClass('top-pad');$('#banner .ad').addClass('top-margin');$('#banner section.tools-expand').addClass('search');var window_top=$(window).scrollTop();var div_top=$('#sticky-anchor').offset().top+30;if(window_top>div_top){$('#sticky-head').addClass('stick');$('.topics.stick-topics, #search-form').addClass('remove');$('li.search-icon').fadeOut("fast");}else{$('#sticky-head').removeClass('stick');$('.topics.stick-topics, #search-form').removeClass('remove');$('li.search-icon').fadeIn("fast");}}if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){if($('#sticky-head').hasClass('stick')){var stickyHeaderHeight=$('section.main').height();stickyHeaderHeight=52;$('header#banner nav#sticky-nav.main').css("top",stickyHeaderHeight);$('#sticky-nav').addClass('stick');$('#sticky-nav').removeClass('no-stick');}else{stickyHeaderHeight=$('header#banner').height();$('header#banner nav#sticky-nav.main').css("top",stickyHeaderHeight);$('#sticky-nav').removeClass('stick');$('#sticky-nav').addClass('no-stick');}}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){var stickyHeaderHeight=$('section.topics').height()+$('#sticky-head.main.stick-head').height();stickyHeaderHeight=stickyHeaderHeight-8;$('header#banner nav#sticky-nav.main').css("top",stickyHeaderHeight);$('#sticky-nav').addClass('stick');if($('#sticky-head').hasClass('stick')){$('#sticky-head.stick').siblings('#sticky-nav').addClass('nav-stick');$('#sticky-head').siblings('#sticky-nav').removeClass('no-stick');}else{$('#sticky-head').siblings('#sticky-nav').removeClass('nav-stick');$('#sticky-head').siblings('#sticky-nav').addClass('no-stick');}}}$(function(){$(window).scroll(sticky_relocate);sticky_relocate();});</script>
<div id="insider-popup" class="modal-box ">
<div class="insider-modal-wrapper">
<div class="modal-header-title">
<div class="modal-banner-insider"><span class="insider"></span></div>
<div class="modal-close close">×</div>
</div>
<div class="modal-body">
<script>$(document).ready(function(){$('a[data-link]').click(function(){var dataLink=$(this).attr('data-link');var toKeep='div[data-link="'+dataLink+'"]';$('div[data-link]').not(toKeep).hide();if($(this).hasClass('link-transition')){$(toKeep).fadeIn(800);}else{$(toKeep).show();}return false;});});</script>
</div>
<div class="modal-footer">
<div class="modal-close close-btn">Close</div>
</div>
</div>
</div>
<script>$(document).ready(function(){var appendthis=("<div class='modal-overlay modal-close'></div>");if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('.modal-box').css({top:10,left:0});}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('.modal-box').height($(document).height());$('.modal-box').css('top','0');}var userAg=navigator.userAgent;$('a[data-modal-id]').click(function(e){e.preventDefault();$('body').append(appendthis);$('.modal-overlay').fadeTo(500,0.9);$('.modal-overlay').height($(document).height());var modalBox=$(this).attr('data-modal-id');if($(".modal-box").hasClass('triggered')||(userAg.indexOf("Firefox")!=-1)){$('#'+modalBox).fadeIn($(this).data());}else{if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('#'+modalBox).toggle('slide',{direction:'up'},800);}else{$('#'+modalBox).toggle('slide',{direction:'left'},600);}}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$("html, body").animate({scrollTop:0},700);$('a.btn.continue-on').click(function(){$('html, body').animate({scrollTop:0},500);});return false;}if(navigator.userAgent.match(/(iPad)/)){$("html, body").animate({scrollTop:0},500);}});$(".modal-close, .modal-overlay").click(function(){$('.select2-drop').css('display','none');$(".modal-overlay").fadeOut(500,function(){$(".modal-overlay").remove();});if($(".modal-box").hasClass('triggered')||(userAg.indexOf("Firefox")!=-1)){$(".modal-box").fadeOut(500);}else{if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('.modal-box').toggle('slide',{direction:'up'},800);}else{$('.modal-box').toggle('slide',{direction:'left'},600);}}});});</script>
<!-- END PAGE HEADER -->
<div id="page-wrapper" class="page-wrapper">
<div id="skinAdTarget"></div>
<section role="main">
<article itemscope itemtype="http://schema.org/Article">
<div class="ticker-ad ad">
<div id="ticker" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("ticker","true");$('#ticker').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: ticker - [971 1115]");</script>
</div>
<!-- Events Header -->
<!-- //end Events Header -->
<header class='cat'>
<nav class="breadcrumbs horiz">
<ul itemscope itemtype="http://data-vocabulary.org/Breadcrumb">
<li><a href="/" itemprop="url"><span itemprop="title">Home</span></a></li>
<li><a href="/category/software/" itemprop="url"><span itemprop="title">Software</span></a></li>
<li><a href="/category/customer-relationship-management/" itemprop="url"><span itemprop="title">CRM</span></a></li>
</ul>
</nav>
<div class="category"><a href="/opinion" itemprop="genre">Opinion</a></div>
<h1 itemprop="headline">Building a customer community: 13 critical questions to get started</h1>
<section class="deck viewability">
<h3 itemprop="description">Salesforce, WordPress, Simplemachines, BB engines…they all have demos for community-building tools that will daze and amaze. But which one’s for you? Don’t go shopping until you’ve answered these questions.</h3>
</section>
<div class="cat-social">
<div id="sharer" class="cat sidecar show">
<ul id="share-tool" class="expand">
<li class="sosh">
<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.cio.com%2Farticle%2F3267576%2Fcustomer-relationship-management%2Fbuilding-a-customer-community-13-critical-questions-to-get-started.html&via=CIOonline&text=Building+a+customer+community%3A+13+critical+questions+to+get+started" target="_blank" onclick="sharingTrack('Twitter-vert', 'twshare')">
<img class="sidecar-icon" src="//idge.staticworld.net/images/twitter.svg"/>
</a>
</li>
<li class="sosh">
<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.cio.com%2Farticle%2F3267576%2Fcustomer-relationship-management%2Fbuilding-a-customer-community-13-critical-questions-to-get-started.html" target="_blank" onclick="sharingTrack('Facebook-vert', 'fblike')">
<img class="sidecar-icon" src="//idge.staticworld.net/images/facebook.svg"/>
</a>
</li>
<li class="sosh">
<a href="http://www.linkedin.com/shareArticle?url=https%3A%2F%2Fwww.cio.com%2Farticle%2F3267576%2Fcustomer-relationship-management%2Fbuilding-a-customer-community-13-critical-questions-to-get-started.html&title=Building+a+customer+community%3A+13+critical+questions+to+get+started" target="_blank" onclick="sharingTrack('LinkedIn-vert')">
<img class="sidecar-icon" src="//idge.staticworld.net/images/linkedin.svg"/>
</a>
</li>
<li class="sosh">
<a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.cio.com%2Farticle%2F3267576%2Fcustomer-relationship-management%2Fbuilding-a-customer-community-13-critical-questions-to-get-started.html" target="_blank" onclick="sharingTrack('GooglePlus-vert', 'googplus')">
<img class="sidecar-icon" src="//idge.staticworld.net/images/gplus.svg"/>
</a>
</li>
<li class="sosh hide">
<a href="http://reddit.com/submit?url=https%3A%2F%2Fwww.cio.com%2Farticle%2F3267576%2Fcustomer-relationship-management%2Fbuilding-a-customer-community-13-critical-questions-to-get-started.html&title=Building+a+customer+community%3A+13+critical+questions+to+get+started" target="_blank" onclick="sharingTrack('Reddit-vert')">
<img class="sidecar-icon" src="//idge.staticworld.net/images/reddit.svg"/>
</a>
</li>
<li class="sosh hide">
<a href="http://www.stumbleupon.com/submit?url=https%3A%2F%2Fwww.cio.com%2Farticle%2F3267576%2Fcustomer-relationship-management%2Fbuilding-a-customer-community-13-critical-questions-to-get-started.html" target="_blank" onclick="sharingTrack('ShareStumbleupPrint-vert')">
<img class="sidecar-icon" src="//idge.staticworld.net/images/stumbleupon.svg"/>
</a>
</li>
<li class="sosh hide">
<a href="#email" id="email-icon">
<img class="sidecar-icon" src="//idge.staticworld.net/images/mail.svg"/>
</a>
</li>
<li class="sosh hide print">
<a href="javascript:window.print();">
<img class="sidecar-icon" src="//idge.staticworld.net/images/print.svg"/>
</a>
</li>
<li class="more">
<div class="more-icon" onclick="document.getElementById('share-tool').className = 'expand';"></div>
</li>
</ul>
</div>
<script type="text/javascript">var isValidEmailAddress=isValidEmailAddress||function(emailAddress){var pattern=new RegExp(/^[+a-zA-Z0-9._-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,5}$/i);return pattern.test(emailAddress);};function encodeQueryData(params){var ret=[];for(var paramKey in params){ret.push(encodeURIComponent(paramKey)+"="+encodeURIComponent(params[paramKey]));}return ret.join("&");}function bindEmailModal(){$('#emailModal').on("click",".close-btn",function(event){event.preventDefault();$('#emailModal').hide();$("#emailModal .eml-friend").show();$(".eml-friend-success").hide();$(".eml-friend-error").hide();$('#emailModal').fadeOut(200);$('#email-to').val('');$('#email-from').val('');$('#name').val('');$('#personalization').val('');$('#eml-from-address-message').html("");$('#eml-to-address-message').html("");$('#eml-friend-captcha-message').html("");});$('#emailModal').on("submit","form",function(event){event.preventDefault();var $form=$(this);var action=$form.attr('action');var formData=$form.serialize();var emailFrom=$('#email-from').val();var emailTo=$('#email-to').val();var uresponse=$('#g-recaptcha-response').val();$('#eml-from-address-message').html("");$('#eml-to-address-message').html("");$('#eml-friend-captcha-message').html("");if(isValidEmailAddress(emailFrom)&&isValidEmailAddress(emailTo)&&uresponse!=""){var eloquaParam={AssetCountforCurrentCampaign:"1",AssetName:"",AssetTopic:"",AssetType:"",BuyingCycle:"",C_Address1:"",C_Address2:"",C_BusPhone:"",C_City:"",C_Company_Size1:"",C_Country:"",C_EmailAddress:"",C_FirstName:"",C_Industry1:"",C_Job_Role1:"",C_LastName:"",C_State_Prov:"",C_Zip_Postal:"",ClientName:"",ProgramName:"",brand:"",elqFormName:"CentralRegistrationMasterForm",formId:"3062313",elqSiteId:1856,elqCustomerGUID:elqCustomerGUID,elqCookieWrite:0,friend_email:emailFrom,friend_article_title:"Building a customer community: 13 critical questions to get started",friend_taxo:"Software",friend_source:"CIO",friend_article_url:"https://www.cio.com/article/3267576/customer-relationship-management/building-a-customer-community-13-critical-questions-to-get-started.html",device_platform:navigator.userAgent};$.ajax("https://secure.p01.eloqua.com/e/f2.aspx",{type:'GET',data:eloquaParam,success:function(data,textStatus,xhr){},error:function(xhr,textStatus,errorThrown){}});var eloquaParamMini={elqCustomerGUID:elqCustomerGUID,friend_taxo:"Software",friend_source:"CIO",device_platform:navigator.userAgent};formData+="&"+encodeQueryData(eloquaParamMini);$.ajax(action,{type:'POST',data:formData,success:function(data,textStatus,xhr){$("#emailModal .eml-friend").hide();$(".eml-friend-success").fadeIn(800);},error:function(xhr,textStatus,errorThrown){$("#emailModal .eml-friend").hide();$(".eml-friend-error").fadeIn(800);}});}else{if(uresponse==""){$('#eml-friend-captcha-message').html("Please verify you're not a robot!");}if(!isValidEmailAddress(emailTo)){$('#eml-to-address-message').html("Please enter a valid email address.");}if(!isValidEmailAddress(emailFrom)){$('#eml-from-address-message').html("Please enter a valid email address.");}}});}$(document).ready(function(){$(document).on("click","#email-icon",function(event){event.preventDefault();bindEmailModal();sharingTrack('Email-vert');$('#emailModal').fadeIn(800);});});</script>
<div class="modal eml-friend-wrapper" id="emailModal" style="display:none;">
<form class="eml-friend" action="/eloquaemail/article?eloqua=true&id=3267576">
<input type="hidden" name="title" value="Building a customer community: 13 critical questions to get started"/>
<input type="hidden" name="url" value="https://www.cio.com/article/3267576/customer-relationship-management/building-a-customer-community-13-critical-questions-to-get-started.html"/>
<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
<h3>Email a friend</h3>
<div class="input-row">
<div id="eml-to-address-message" class="error-msg"></div>
<h4 class="input-label">To</h4>
<input id="email-to" value="" placeholder="Email address (required)" type="email" name="recipients" tabindex="1">
<p class="addl-text">Use commas to separate multiple email addresses</p>
</div>
<hr/>
<div class="input-row">
<div id="eml-from-address-message" class="error-msg"></div>
<h4 class="input-label">From</h4>
<input id="name" value="" placeholder="Name (optional)" type="text" name="name" tabindex="2">
</div>
<div class="input-row">
<input id="email-from" value="" placeholder="Email address (required)" type="email" name="sender" tabindex="3">
</div>
<div class="input-row">
<textarea name="message" placeholder="Check out this article I found on CIO." id="personalization" tabindex="4"></textarea>
</div>
<hr/>
<div class="input-row">
<div id="eml-friend-captcha-message" class="error-msg"></div>
<script src="https://www.google.com/recaptcha/api.js" async defer></script>
<div class="g-recaptcha" data-sitekey="6LczmkcUAAAAANEO7J277KwH6Kzp6BEQjPTWP4S4"></div>
</div>
<hr/>
<div class="submit">
<input type="submit" value="Send" class="input-submit" tabindex="5">
<a href="/about/privacy.html" class="submit-privacy" target="_blank">Privacy Policy</a>
</div>
</form>
<div class="eml-ty eml-friend-success" style="display:none;">
<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
<h3>Thank you</h3>
<p class="msg-sent">Your message has been sent.</p>
</div>
<div class="eml-friend-error" style="display:none;">
<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
<h3>Sorry</h3>
<p class="msg-sent">There was an error emailing this page.</p>
</div>
</div>
</div>
<div class="cat byline vcard author ">
<div class="byline-wrapper">
<p class="name" itemscope itemtype="http://schema.org/Person" itemprop="author">
<span class="by">By </span><span class="fn" itemprop="name"><a rel="author" itemprop="url" href="/author/David-Taber/"><span itemprop="name">David Taber</span></a></span>
</p>
<p class="dateline">
<span itemprop="publisher" itemscope itemtype="http://schema.org/Organization"><span class="publisher" itemprop="name">CIO</span><meta itemprop="logo" content="https://idge.staticworld.net/cio/CIO_logo_300x300.png"/></span> <span class="divider">|</span>
<span class="pub-date" itemprop="datePublished" content="2018-04-09T02:56-0700">Apr 9, 2018 2:56 AM
PT
</span>
</p>
</div>
</div>
<div class="ad viewability">
<div id="topleaderboard" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("topleaderboard","true");$('#topleaderboard').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: topleaderboard - [971 1115]");</script>
</div>
</header>
<figure itemprop="image" itemscope itemtype="http://schema.org/ImageObject" class="hero-img">
<meta itemprop="representativeOfPage" content="1"/>
<meta itemprop="height" content="467"/>
<meta itemprop="width" content="700"/>
<img src="https://images.idgesg.net/images/article/2018/01/group-of-people-applauding_agreement_community-100746938-large.jpg" alt="group of people applauding agreement community" itemprop="contentUrl" itemprop="url"/>
<figcaption>
<span class="credit" itemprop="copyrightHolder">
Thinkstock
</span>
</figcaption>
</figure>
<section class="epo cat-narrow" id="drr-top-ad">
<!-- Related -->
<div class="related-promo-wrapper">
<div class="promo apart">
<div class="hed">More like this</div>
<ul class="">
<li class="clearfix with-image">
<a href="/article/3219855/customer-relationship-management/deduping-in-salesforce-the-complete-how-to.html"><img class="small.3x2Image  imgId100688920 " src="https://images.techhive.com/images/article/2016/10/twins-dual-boot-100688920-small.3x2.jpg" alt="twins dual boot" itemprop="image"/></a>
<div class="item">
<div class="title"><a href="/article/3219855/customer-relationship-management/deduping-in-salesforce-the-complete-how-to.html">Deduping in Salesforce: The complete how-to</a></div>
</div>
</li>
<li class="clearfix with-image">
<a href="/article/3085630/customer-relationship-management/11-crm-best-practices.html"><img class="small.3x2Image  imgId100440231 " src="https://images.techhive.com/images/article/2014/09/crm-100440231-small.3x2.jpg" alt="crm" itemprop="image"/></a>
<div class="item">
<div class="title"><a href="/article/3085630/customer-relationship-management/11-crm-best-practices.html">8 CRM implementation best practices</a></div>
</div>
</li>
<li class="clearfix with-image">
<a href="/article/3243324/customer-relationship-management/crm-vs-marketing-automation-whats-the-difference-and-which-do-you-need.html"><img class="carousel.idgeImage  imgId100638792 " src="https://images.techhive.com/images/article/2016/01/marketing-automation-100638792-carousel.idge.jpeg" alt="marketing automation gears" itemprop="image"/></a>
<div class="item">
<div class="title"><a href="/article/3243324/customer-relationship-management/crm-vs-marketing-automation-whats-the-difference-and-which-do-you-need.html">CRM vs. marketing automation: What&#039;s the difference and which do you need?</a></div>
</div>
</li>
<li class="clearfix with-image">
<a class="play" href="/video/77636/cio-career-coach-bringing-a-product-management-mindset-to-it"><i class="ss-play"></i></a>
<a href="/video/77636/cio-career-coach-bringing-a-product-management-mindset-to-it"><img class="small.3x2Image  imgId100722472 " src="https://images.techhive.com/images/article/2017/05/ciocc_pt3.00_00_02_05.still001-100722472-small.3x2.jpg" alt="ciocc pt3.00 00 02 05.still001" itemprop="image"/></a>
<div class="item">
<div class="item-eyebrow">Video</div>
<div class="title"><a href="/video/77636/cio-career-coach-bringing-a-product-management-mindset-to-it">CIO Career Coach: Bringing a product management mindset to IT</a></div>
</div>
</li>
</ul>
</div>
</div>
<div class="ad top-ad">
<div id="topimu" class="adunit ad-container">
</div>
<script type="text/javascript">if($(window).width()>=930){IDG.GPT.addDisplayedAd("topimu","true");$('#topimu').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: topimu - [971 1115]");}</script>
</div>
</section>
<section class="bodee">
<div class="ad placement">
<!--  Begin gpt-skin/inread -->
<div id="inread" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("inread","true");IDG.GPT.displayGoogleTagSlot('inread');</script>
<!--  End gpt-skin/inread -->
</div>
<script>var dataLayer=window.dataLayer=window.dataLayer||[];dataLayer.push({'event':'loadTopCollectionModule'});</script>
<script type="text/javascript">$(document).ready(function(){$('.articleBloxAd').filter(":visible").each(function(index,item){var id=$(item).attr('id');var divClass=$(item).attr('class');var adString=IDG.GPT.getLazyAdCode();$(item).replaceWith("<div id=\""+id+"\" class=\"lazyload_blox_ad "+divClass+"\">"+adString+"</div>");});try{$("div.lazyload_blox_ad").lazyLoadAd({threshold:0,forceLoad:false,onLoad:false,onComplete:false,timeout:1500,debug:false,xray:false});}catch(exception){console.log("error loading lazyload_ad "+exception);}});</script>
<script type="text/javascript">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</script>
<div id="drr-container" class='cat ' itemprop="articleBody">
<p>Lead generation means user education. Channel management means a partner portal. Case management means a knowledge base, customer discussion groups, and a support forum. Customer loyalty means a customer portal.  It’s all about building a community site.</p><p>Depending on where you start, you’ll hear about dozens of product offerings and see some extraordinary demos. The best of the demos will live up to Sybase founder Bob Epstein’s famous quote about benchmarks: “they are what the vendor can guarantee you will never achieve.”</p><aside id="fsb-1894" class="fakesidebar"><p>[ Learn <a href="http://www.cio.com/article/3178080/cio-role/how-crm-buyers-can-negotiate-the-best-deal.html">how CRM buyers can negotiate the best deal</a> | Screen Salesforce consultants with these <a href="https://www.cio.com/article/3209673/how-to-choose-the-best-salesforce-consultant-for-success.html">25 key questions</a>. | <a href="http://cio.com/newsletters/signup.html" rel="nofollow">Sign up for CIO newsletters</a>. ]</p></aside><p>Before you get dazzled by bright shiny objects, you really have to go off and do some thinking: that’s right, dull homework. Because any of the community-building products could be the right one for you, but all of them will result in a failure if you haven’t answered most of these questions in advance:</p><ol>
<li>What's the fundamental value of building/maintaining the community?</li>
<ul>
<li>Getting more prospects or partners sooner?</li>
<li> Improving the quality of your decisions?</li>
<li>Making your company look better / more visible?</li>
<li>Accelerating your prospects evolution?</li>
<li>Increasing customer or channel loyalty?</li>
<li>Helping you catch up to Competitors’ sites?</li>
<li>Making management feel better?</li>
</ul>
<li>How many people will be in the community?</li>
<ul>
<li>Will this be a "public community," where users can spontaneously register themselves?  Or is this by invitation (and pre-setup) only?</li>
<li>Will there be sub-groups?</li>
<li>How many active threads do you expect at any one time?</li>
<li>Will users be allowed to start their own threads?</li>
</ul>
<li>What are the users’ job titles (both the company and the role)?</li>
<ul>
<li>What is their level of knowledge about your company and its products?</li>
<li>How will you manage excluding users from certain countries?</li>
<li>How will you get to full GPDR compliance?</li>
</ul>
<li>What are the usage patterns?</li>
<ul>
<li>Will users come in via single sign-on (SSO) or direct login?</li>
<li>Will they coming in from a mobile device?</li>
<li>How often do you expect them to log in?</li>
<li>How long will they stay on the site?</li>
<li>Are there any things about their usage session that we’ll need to know / report on / get alerted about?</li>
</ul>
<li>What do they come to the community for? </li>
<ul>
<li>What are they trying to achieve <em>any time</em>they log in?</li>
<li>With whom are they trying to communicate?</li>
<li>What information do they seek?</li>
<li>What information do they want to share?</li>
<li>What information are they allowed to download?</li>
<li>What things can they report on (if any)?</li>
</ul>
<li>What do they need to be able to hide from others?</li>
<ul>
<li>About themselves and</li>
<li>About the information they post</li>
</ul>
<li>How much information will there be in a given year?</li>
<ul>
<li>Number of topics</li>
<li>Number of posts and attachments from you</li>
<li>Number of posts and attachments from users</li>
<li>Number of leads</li>
<li>Number of deals</li>
<li>Number of ideas/suggestions</li>
<li>Number of cases/resolutions</li>
<li>What of this information is transactional in nature (i.e., not just a content posting)?</li>
<li>What of this information needs to be integrated with other systems (e.g., CRM)?</li>
<li>Will the "information architecture" (read: navigation) need to change on a regular basis?</li>
</ul>
<li>What's the "memory horizon" of the community?</li>
<ul>
<li>What will be your content archiving strategy?</li>
<li>Do some things get hidden from users after a few months?</li>
<ul>
<li>Can this be automatic?</li>
<li>Do we actually want a human always involved in the "sunsetting" of information?</li>
</ul>
</ul>
<li>Do you want to have the community moderated?</li>
<ul>
<li>If so, can it be done "by exception" or does every moderation action have to be done manually?</li>
<li>What are the legal terms of use you are expecting?</li>
</ul>
<li>What analytics do you need?</li>
<ul>
<li>Real time alerts regarding usage patterns, DOS attacks?</li>
<li>Social media monitoring?</li>
<li>Daily reports, executive dashboards?</li>
</ul>
<li>What's your internal constituency?</li>
<ul>
<li>Worker bees by department?</li>
<li>PR, marketing, sales, support, operations and legal executives?</li>
<li>Board?</li>
</ul>
<li>What's your willingness to spend?</li>
<ul>
<li>On user licenses?</li>
<li>On development?</li>
<li>On ongoing moderation? This is just internal hours, but you want to have some sort of threshold like "no more than 50 hours/week".</li>
</ul>
<li>Who’s going to own the project and budget?</li>
<ul>
<li>For project management and deployment</li>
<li>For community membership growth</li>
<li>For moderation and legal policing</li>
<li>For ongoing maintenance and technical expansion</li>
</ul>
</ol><p>I know, this is quite the laundry list!  But if you don’t bring up these issues early, you won’t really know what your requirements are, so your product evaluation criteria will be foggy at best.  Save yourself some time and money by starting at the beginning.</p><aside class="nativo-promo nativo-promo-1 smartphone" id=""> </aside><aside id="fsb-2400" class="fakesidebar">
<p><strong>More on CRM:</strong></p>
<ul>
<li><a href="https://www.cio.com/article/2439505/customer-relationship-management/customer-relationship-management-crm-definition-and-solutions.html#tk.cio_rs"> What is a CRM system? Your guide to customer relationship management </a></li>
<li><a href="https://www.cio.com/article/3243324/customer-relationship-management/crm-vs-marketing-automation-whats-the-difference-and-which-do-you-need.html">CRM vs. marketing automation: What's the difference and which do you need?</a></li>
<li><a href="https://www.cio.com/article/3261568/customer-relationship-management/best-free-crm-software-2018-7-top-tools.html">Best free CRM software, 2018: 7 top tools</a></li>
<li><a href="https://www.cio.com/article/2381909/customer-relationship-management/what-to-do-when-your-crm-project-fails.html#tk.cio_rs">What to do when your CRM project fails </a></li>
<li><a href="https://www.cio.com/article/2426662/data-center/the-9-dirty-little-secrets-of-crm.html">The 9 dirty little secrets of CRM</a></li>
</ul></aside>
<div class="end-note">
<!-- blx4 #2003 blox4.html  -->
<div id="" class="blx blxParticleendnote blxM2003  blox4_html  blxC35767"><p><strong>Next read this:</strong></p>
<ul>
<li>
<a href="https://www.cio.com/article/3196728/careers-staffing/the-working-dead-it-jobs-bound-for-extinction.html#tk.cioendnote">The working dead: IT jobs bound for extinction</a>
</li>
<li>
<a href="https://www.cio.com/article/3263732/its-most-wanted-16-traits-of-indispensable-it-pros.html#tk.cioendnote">IT’s most wanted: 16 traits of indispensable IT pros</a>
</li>
<li>
<a href="https://www.cio.com/article/3158677/8-common-resume-mistakes-and-how-to-fix-them.html#tk.cioendnote">8 common resume mistakes (and how to fix them)</a>
</li>
<li>
<a href="https://www.cio.com/article/3137946/6-trends-that-will-shape-cloud-computing-in-2017.html#tk.cioendnote">6 trends shaping cloud strategies today</a>
</li>
<li>
<a href="https://www.cio.com/article/3252096/8-early-warning-signs-of-it-disaster.html#tk.cioendnote">8 early warning signs of IT disaster</a>
</li>
</ul>
</div>
</div>
</div>
<script>$("a[data-product-id]").on('click',function(e){var e=e||window.event;var dataLayer=window.dataLayer=window.dataLayer||[];var prodName=$(this).attr("data-product-name");prodName=prodName.replace("\\'","'");if($(this).parents('.slideshow').length>0){var productLinkPosition="Slideshow";}else if($(this).parents('.product-sb').length>0){var productLinkPosition="Product Sidebar";}else if($(this).parents('.at-a-glance.top').length>0){var productLinkPosition="AAG Top";}else if($(this).parents('.at-a-glance').length>0){var productLinkPosition="AAG Bottom";}else if($(this).parents('.product-chart').length>0){var productLinkPosition="Product Chart";}else if($(this).parents('.product-list').length>0){var productLinkPosition="Product List";}else{var productLinkPosition="Body Text";}dataLayer.push({'event':'affiliateLink','eventCategory':'Affiliate Link','eventAction':'Click','eventLabel':''+e.target+'','productVendor':$(this).attr("data-bkvndr"),'productManufacturer':$(this).attr("data-bkmfr"),'productName':prodName,'productId':$(this).attr("data-product-id"),'productLinkPosition':productLinkPosition});});</script>
<script>$("#drr-container a").on('click',function(e){var dataLayer=window.dataLayer=window.dataLayer||[];var $clickEl=$(this);var clickUrl=$clickEl.attr("href");var clickParentsUntilDrr=$clickEl.parentsUntil("#drr-container");var clickText=$clickEl.text().trim();var linkLocation;var linkType;var regex=new RegExp("cio|csoonline|computerworld|itnews|itworld|infoworld|networkworld|javaworld|techconnect|techhive|macworld|pcworld|greenbot|gamestar","i");if(clickParentsUntilDrr.hasClass("fakesidebar")){linkLocation="FSB";}else if(clickParentsUntilDrr.hasClass("end-note")){linkLocation="End Note";}else{linkLocation="Body";}if(regex.test(clickUrl)){linkType="Internal";}else{linkType="External";}dataLayer.push({'event':'editBodyLink','eventCategory':'Editorial Body Links','eventAction':linkType,'eventLabel':linkLocation+" | "+clickText+" | "+clickUrl});});</script>
<div class="apart-alt tags">
<span class="related">Related: </span>
<ul>
<li><a href="/category/customer-relationship-management">CRM</a></li>
<li><a href="/category/software">Software</a></li>
</ul>
</div>
<div class="byline vcard author end-byline">
<div class="author-info">
<p class="bio">David Taber is the author of the Prentice Hall book, "Salesforce.com Secrets of Success," now in its second edition, and is the CEO of SalesLogistix, a certified Salesforce.com consultancy focused on business process improvement through use of CRM systems. SalesLogistix clients are in North America, Europe, Israel and India. Taber has more than 25 years of experience in high tech, including 10 years at the VP level or above.</p>
</div><!-- end .author-info -->
<div class="brand-social">
<div class="follow-text">Follow</div>
<ul class="social-links">
<li>
<a href="/author/David-Taber/">
<i class="ss-icon ss-user"></i>
</a>
</li>
<li>
<a href="https://twitter.com/DavidTaber" class="twitter-follow" target="_blank">
<i class="ss-icon ss-social ss-twitter"></i>
</a>
</li>
<li>
<a href="/author/David-Taber/index.rss" class="rss">
<i class="ss-icon ss-social ss-rss"></i>
</a>
</li>
</ul>
</div>
</div>
<!-- blx4 #1170 blox4.html  -->
<div class="article-intercept">
<i class="ss-icon ss-lightbulb"></i> <a href="https://www.cio.com/article/3250845/digital-transformation/state-of-the-cio-2018-it-business-alignment-finally-gets-real.html">NEW! State of the CIO, 2018: IT-business alignment (finally) gets real</a>
</div>
<script src="/www/js/video/embedder.js"></script>
</section><!-- /.bodee -->
<div id="content-recommender" class="nolinks norewrite">
<div class="head">You Might Like</div>
<div id="rcjsload_eab3cb"></div>
<script type="text/javascript">(function(){function ad_block_test(e,o){if("undefined"!=typeof document.body){var t="0.1.2-dev",o=o?o:"sponsorText",n=document.createElement("DIV");n.id=o,n.style.position="absolute",n.style.left="-999px",n.appendChild(document.createTextNode("&nbsp;")),document.body.appendChild(n),setTimeout(function(){if(n){var o=0==n.clientHeight;try{}catch(d){console&&console.log&&console.log("ad-block-test error",d)}e(o,t),document.body.removeChild(n)}},175)}}ad_block_test(function(is_blocked){var widget_id=30203;if(is_blocked===true){widget_id=30279;}var referer="";try{if(referer=document.referrer,"undefined"==typeof referer)throw"undefined"}catch(exception){referer=document.location.href,(""==referer||"undefined"==typeof referer)&&(referer=document.URL)}referer=referer.substr(0,700);var rcel=document.createElement("script");rcel.id='rc_'+Math.floor(Math.random()*1000);rcel.type='text/javascript';rcel.src="//trends.revcontent.com/serve.js.php?w=30203&t="+rcel.id+"&c="+(new Date()).getTime()+"&width="+(window.outerWidth||document.documentElement.clientWidth)+"&referer="+referer+'&is_blocked='+is_blocked;rcel.async=true;var rcds=document.getElementById("rcjsload_eab3cb");rcds.appendChild(rcel);});})();</script>
</div>
<div class="lazyload_ad">
<code type="text/javascript">
<!--
		document.write('<div id="ciu" class=" ad-container">');
		IDG.GPT.addDisplayedAd("ciu", "true");
		IDG.GPT.addLazyloadedAd("ciu", "true");
		document.write('</div>');
		$('#ciu').responsiveAd({screenSize:'971 1115', scriptTags: []});
		if (Object.keys(IDG.GPT.companions).length > 0 || IDG.GPT.disableInitialLoad) {
			IDG.GPT.refreshAd('ciu');
		}
		//-->
</code>
</div>
<link rel="stylesheet" href="/www.idge/css/sponsored-links.css?v=20180405115135"/>
<link rel="stylesheet" href="/www.idge.cio/css/sponsored-links.css?v=20180405115135"/>
<section id="resources-sponsored-links">
<section class="sponsored-links">
<div class="head">Sponsored Links</div>
<ul class="first">
<li>
<a rel="nofollow" target="_blank" href="http://pubads.g.doubleclick.net/gampad/clk?id=4516338905&iu=/8456/IDG.US_E_CIO.com" onclick="moduleTrack('Sponsored Links','resources-sponsored-links component')">
INSTANTLY dtSearch® TERABYTES of FILE+EMAIL+DB+WEB DATA; reviews & evals
</a>
</li>
</ul>
</section>
</section>
</article>
</section><!-- /role=main -->
</div><!-- /#page-wrapper -->
<link rel="stylesheet" href="/www.idge/css/foot.css?v=20180405115135"/>
<link rel="stylesheet" href="/www.idge.cio/css/foot.css?v=20180405115135"/>
<footer>
<section class="brand" itemscope itemtype="http://schema.org/Organization">
<link itemprop="url" href="http://www.cio.com">
<a href="/"><span class="logo">CIO</span></a>
<span class="tagline"> </span>
<span class="follow">
<label>Follow us</label>
<ul>
<li><a href="https://twitter.com/CIOonline" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Twitter')"><i class="ss-icon ss-social-circle ss-twitter"></i></a></li>
<li><a href="https://www.linkedin.com/company/cio-online" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('LinkedIn')"><i class="ss-icon ss-social-circle brand ss-linkedin"></i></a></li>
<li><a href="https://www.facebook.com/CIOfacebook" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Facebook')"><i class="ss-icon ss-social-circle brand ss-facebook"></i></a></li>
<li><a href="https://plus.google.com/+CIOOnline" itemprop="sameAs" rel="publisher" target="_blank" onclick="brandFollowTrack('Google+')"><i class="ss-icon ss-social-circle brand ss-googleplus"></i></a></li>
<li><a href="https://www.youtube.com/user/CIOtv" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('YouTube')"><i class="ss-icon ss-social-circle brand ss-youtube"></i></a></li>
<li><a href="/index.rss" target="_blank"><i class="ss-icon ss-social-circle ss-rss"></i></a></li>
</ul>
</span>
</section>
<section class="topics">
<nav id="ft2">
<ul>
<li><a href="/feature">Feature</a></li>
<li><a href="/news">News</a></li>
<li><a href="/news-analysis">News Analysis</a></li>
<li><a href="/opinion">Opinion</a></li>
<li><a href="/slideshows">Slideshows</a></li>
<li><a href="/video">Videos</a></li>
</ul>
</nav>
<nav id="ft2a">
<ul>
<li><a href="/newsletters/signup.html">Sign up for Newsletters</a></li>
<li><a href="/insider">Sign up for Insider</a></li>
</ul>
</nav>
</section>
<section class="about">
<div class="wrapper">
<nav class="tertiary" id="ft3">
<ul>
<li><a href="/about/about.html">About CIO</a>
<li><a href="/about/adchoices.html">Ad Choices</a>
<li><a href="https://www.idgenterprise.com/reach/cio/" target="_blank" rel="nofollow">Advertising</a>
<li><a href="https://www.idg.com/work-here/" target="_blank" rel="nofollow">Careers at IDG</a>
<li><a href="/about/contactus.html">Contact Us</a>
<li><a href="/about/affiliates.html">E-commerce Affiliate Relationships</a>
<li><a href="/about/privacy.html">Privacy Policy</a>
<li><a href="/about/tos.html">Terms of Service</a>
</ul>
</nav>
</div>
</section>
<section class="copyright">
<div class="wrapper">
<p><a href="/about/tos.html">Copyright</a> &copy; 2018 IDG Communications, Inc.</p>
<div class="network">
<div id="network-selector">
<div class="label">Explore the IDG Network <i class="ss-icon tick">descend</i></div>
<ul>
<li><a href="https://www.cio.com" target="_blank" rel="nofollow">CIO</a></li>
<li><a href="https://www.computerworld.com" target="_blank" rel="nofollow">Computerworld</a></li>
<li><a href="https://www.csoonline.com" target="_blank" rel="nofollow">CSO</a></li>
<li><a href="https://www.gamestar.com" target="_blank" rel="nofollow">GameStar</a></li>
<li><a href="https://www.greenbot.com" target="_blank" rel="nofollow">Greenbot</a></li>
<li><a href="https://www.idc.com" target="_blank" rel="nofollow">IDC</a></li>
<li><a href="https://www.idg.com" target="_blank" rel="nofollow">IDG</a></li>
<li><a href="https://www.idgconnect.com" target="_blank" rel="nofollow">IDG Connect</a></li>
<li><a href="https://www.idgtechnetwork.com" target="_blank" rel="nofollow">IDG TechNetwork</a></li>
<li><a href="https://www.idg.tv" target="_blank" rel="nofollow">IDG.TV</a></li>
<li><a href="https://www.idgventures.com" target="_blank" rel="nofollow">IDG Ventures</a></li>
<li><a href="https://www.infoworld.com" target="_blank" rel="nofollow">Infoworld</a></li>
<li><a href="https://www.itnews.com" target="_blank" rel="nofollow">IT News</a></li>
<li><a href="https://www.itwhitepapers.com" target="_blank" rel="nofollow">ITwhitepapers</a></li>
<li><a href="https://www.itworld.com" target="_blank" rel="nofollow">ITworld</a></li>
<li><a href="https://www.javaworld.com" target="_blank" rel="nofollow">JavaWorld</a></li>
<li><a href="https://www.linuxworld.com" target="_blank" rel="nofollow">LinuxWorld</a></li>
<li><a href="https://www.macworld.com" target="_blank" rel="nofollow">Macworld</a></li>
<li><a href="https://www.networkworld.com" target="_blank" rel="nofollow">Network World</a></li>
<li><a href="https://www.pcworld.com" target="_blank" rel="nofollow">PCWorld</a></li>
<li><a href="https://www.techconnect.com" target="_blank" rel="nofollow">TechConnect</a></li>
<li><a href="https://www.techhive.com" target="_blank" rel="nofollow">TechHive</a></li>
</ul>
</div><!-- /#network-selector -->
</div><!-- /.network -->
</div><!-- /.wrapper -->
</section>
</footer>
<script src="/www/js/analytics/mouse_down.js"></script>
<script src="/www/js/jquery/jquery-ui.js"></script>
<script src="/www/js/jquery/jquery.dfp.min.js"></script>
<script src="/www.idge/js/mule/shortstack_nav.js"></script>
<div id="mobilewelcomead" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("mobilewelcomead","true");$('#mobilewelcomead').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: mobilewelcomead - [971 1115]");</script>
<script src="/www/js/analytics/tracking.js"></script>
<script src="/www/js/autocomplete.js"></script>
<script src="/www.idge/js/social_sidecar.js"></script>
<script src="/www.idge/js/jquery/plugins/jquery.colorbox-min.js"></script>
<script src="/www.idge/js/article.js?v=20180405115135"></script>
<script src="/www/js/prettify.js"></script>
<script src="/www.idge/js/jquery/responsive-tables.js"></script>
<script src="/www.idge/js/jquery/jquery.tablesorter.min.js"></script>
<script>$(document).ready(function(){$("table.tablesorter").tablesorter({widgets:['zebra']});$("table.tablesorter tbody tr").hover(function(){$(this).toggleClass("selected");});$("table.tablesorter thead tr th").each(function(){if($(this).find('.ss-icon').length<1){$(this).append('<i class="ss-icon"></i>');}});});</script>
<script src="/www/js/jquery/jquery.lazyload.min.js"></script>
<script src="/www.idge/js/global.js?v=20180405115135"></script>
<script src="/www/js/webfonts/ss-social.js"></script>
<script src="/www/js/webfonts/ss-standard.js"></script>
<script src="/www/js/analytics/brandAnalytics.js"></script>
<!-- Begin BlueKai Tag -->
<iframe name="__bkframe" height="0" width="0" frameborder="0" src="javascript:void(0)"></iframe>
<script type="text/javascript" src="https://tags.bkrtx.com/js/bk-coretag.js"></script>
<!-- CryptoJS -->
<script src="/www/js/utils/md5.js"></script>
<script type="text/javascript" src="/www/js/analytics/idg_bk_coreapi.js"></script>
<script type="text/javascript">bk_allow_multiple_calls=true;var blueKaiId=14337;var blueKaiPort=10;var brandCode="cio";var regUrl="https://regdev.idge.int/api/"
var daysToRefresh=30;var bk_debug_log=false;regUrl="https://reg.idgenterprise.com/api/";daysToRefresh=30;if(typeof(s)!='undefined'){bk_addPageCtx("pageType",(typeof(s.pageType)!='undefined')?s.pageType:'');}bk_addPageCtx("cmscatids","[3732,3029]");bk_addPageCtx("cmpy","[]");bk_addPageCtx('tid','5');bk_addPageCtx("purchaseintent","awareness");params=getUrlParams('phint');if(Object.keys(params).length>0){bk_addPageCtx("idg_eid",params['idg_eid']);bk_addPageCtx("newt",params['newt']);bk_addPageCtx("isnl","1");}try{IDG.bkCoreApi.start();}catch(e){bk_doJSTag(blueKaiId,blueKaiPort);if(window.console&&window.console.log){window.console.log("Error Occured While Processing Profile Siubmission")}}$('article, #slideshowCarousel').on('click','.product-list-price, .btn-amazon, .productLink',function(e){var $linkEl=$(e.target);var po=$linkEl.data('po');if($.inArray(po,['amazon','vendor','other'])>=0){if(po=='amazon'){var prCat=$linkEl.data('bkc');if(typeof prCat!='undefined'){bk_addPageCtx('event','AmazonClick'+prCat);}bk_addPageCtx('event','AmazonClickCRM');bk_addPageCtx('event','AmazonClickSoftware');}var prMfr=$linkEl.data('bkmfr');if(typeof prMfr!='undefined'){bk_addPageCtx('event','eCommerceMFR'+prMfr);}var prVndr=$linkEl.data('bkvndr');if(typeof prVndr!='undefined'){bk_addPageCtx('event','eCommerceClickVendor'+prVndr);}bk_doJSTag(34202,1);}});</script>
<!-- End BlueKai Tag -->
<div id="catfish" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("catfish","true");$('#catfish').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: catfish - [971 1115]");</script>
<!--  Begin gpt-skin/inread -->
<div id="gpt-skin" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("gpt-skin","true");IDG.GPT.displayGoogleTagSlot('gpt-skin');</script>
<!--  End gpt-skin/inread -->
<script type="text/javascript" src="/www/js/ads/jquery.lazyload-ad.js"></script>
<script type="text/javascript">$("div.lazyload_ad").lazyLoadAd({threshold:0,forceLoad:false,onLoad:false,onComplete:false,timeout:1500,debug:false,xray:false});</script>
<script type='text/javascript'>g_arrModules['']=true;g_arrModules['Article Detail:Top:Breadcrumb']=true;g_arrModules['Article Detail:Social Sharing Vertical']=true;g_arrModules['']=true;g_arrModules['']=true;$('#resources-sponsored-links').addClass('show');</script>
<!-- Begin comScore Tag -->
<script>var _comscore=_comscore||[];_comscore.push({c1:"2",c2:"6035308",c3:"",c5:"CRM",c6:"Article: Opinion",c15:"3267576"});(function(){var s=document.createElement("script"),el=document.getElementsByTagName("script")[0];s.async=true;s.src=(document.location.protocol=="https:"?"https://sb":"http://b")+".scorecardresearch.com/beacon.js";el.parentNode.insertBefore(s,el);})();</script>
<noscript>
<img src="https://sb.scorecardresearch.com/p?c1=2&c2=6035308&cv=2.0&cj=1"/>
</noscript>
<!-- End comScore Tag -->
<script language="JavaScript" type="text/javascript">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</script>
<!-- SiteCatalyst code version: H.26.2.
Copyright 1996-2013 Adobe, Inc. All Rights Reserved
More info available at http://www.omniture.com -->
<script language="JavaScript" type="text/javascript" src="/www.idge/js/analytics/s_code.js"></script>
<script language="JavaScript" type="text/javascript" id="omniVars">g_sOmnitureReportSuite=typeof g_sOmnitureReportSuite!='undefined'&&g_sOmnitureReportSuite?g_sOmnitureReportSuite:"cxociocom";s.pageName="CIO:article:opinion:CRM:3267576:Building a customer community: 13 critical questions to get started";s.pageType="";if(typeof omnitureChannel!='undefined'){s.channel=omnitureChannel;}s.prop1="source:cio";s.eVar1="D=c1";s.prop2="content type:opinion";s.eVar2="D=c2";s.prop3="display type:article:opinion";s.eVar3="D=c3";s.prop4="0 days";s.eVar4="D=c4";s.prop6="";s.prop7="";s.eVar7="D=c7";s.prop9="category:crm";s.eVar9="D=c9";s.prop11="published:09-Apr-18";s.eVar11="D=c11";s.prop12="aid:3267576";s.eVar12="D=c12";s.prop13="";s.eVar13="D=c13";s.prop14="author:david taber";s.eVar14="D=c14";s.prop15="page number:1";s.eVar15="D=c15";s.prop17="uri:/article/3267576/customer-relationship-management/building-a-customer-community-13-critical-questions-to-get-started.html";s.eVar17="D=c17";s.prop18="";s.eVar18="D=c18";s.prop24=getLoginStatusForOmniture();s.eVar24="D=c24";s.prop28=getTrackingToken('tk')?"tokens:"+getTrackingToken('tk'):"";s.eVar28="D=c28";s.prop37="rpn:cio:opinion:cio:article:opinion:crm:3267576:building a customer community: 13 critical questions to get started";s.eVar37="D=c37";s.prop39="";s.eVar39="D=c39";s.prop40="";try{s.prop41=IDG.GPT.getDisplayedAds(',')+','+IDG.GPT.getOtherAds(',');s.prop42=IDG.GPT.getModules(',');s.eVar42="D=c42";}catch(e){console.log("error in setting omniture vars: "+e);}s.prop53="3732";s.eVar53="D=c53";s.prop54="crm,software";s.eVar30="D=c54";s.eVar33=s.prop55="3732,3029";s.eVar33="D=c55";s.prop56="";s.eVar40="D=c56";s.prop61="";s.eVar10="D=c61";s.prop63="awareness";s.prop74="architecture";s.eVar58="D=c74";s.prop75="enterprise-applications";s.eVar60="D=c75";s.prop58="architecture:enterprise-applications";s.eVar59="D=c58";var sModules='';for(var i in g_arrModules){if(g_arrModules[i]&&i!=''){sModules+=i+',';}}sModules=sModules.replace(/,$/,'');s.prop42=sModules;s.eVar42="D=c42";s.events="";s.events=s.apl(s.events,'event33',',');s.eVar41="09-Apr-18";s.list3=s.prop42+","+s.eVar42;for(var p in s){if(s[p]&&p.match(/^(prop|ceVar)\d+$/)){s[p]=s[p].toLowerCase();}}s.campaign=s.getQueryParam('cid');var s_code=s.t();if(s_code)document.write(s_code)</script>
<script language="JavaScript" type="text/javascript">if(navigator.appVersion.indexOf('MSIE')>=0)document.write(unescape('%3C')+'\!-'+'-')</script><noscript><img src="http://idgenterprise.d1.sc.omtrdc.net/b/ss/cxociocom/1/H.25--NS/0" height="1" width="1" border="0" alt=""/></noscript><!--/DO NOT REMOVE/-->
<!-- End SiteCatalyst code version: H.26.2. -->
<script type="text/javascript">$thm.logPlEvent({"b":"cio","e":"view","t":"article","id":"3267576"});</script>
<div id="loginModal"></div>
<div id="logoffModal"></div>
<script type="text/javascript">a=top;f=self;if(a!=f){a.location=f.location;}</script>
</body>
</html>